Requerimientos para Aprendizaje Profundo en Python

Avatar Tutor | abril 25, 2019

En este capítulo, aprenderemos sobre el entorno configurado para Python Deep Learning. Tenemos que instalar el siguiente software para hacer algoritmos de aprendizaje profundo.

Python 2.7+

  • Scipy con Numpy
  • Matplotlib
  • Theano
  • Keras
  • TensorFlow

Se recomienda encarecidamente que Python, NumPy, SciPy y Matplotlib se instalen a través de la distribución Anaconda. Viene con todos esos paquetes.

Necesitamos asegurarnos de que los diferentes tipos de software estén instalados correctamente.

Vayamos a nuestro programa de línea de comandos y escribamos el siguiente comando

$ python

A continuación, podemos importar las bibliotecas requeridas e imprimir sus versiones.

import numpy
print numpy.__version__

Instalación de Theano, TensorFlow y Keras.

Antes de comenzar con la instalación de los paquetes – Theano, TensorFlow y Keras, debemos confirmar si el pip está instalado. El sistema de gestión de paquetes en Anaconda se llama el pip.

Para confirmar la instalación de pip, escriba lo siguiente en la línea de comando:

$pip

Una vez que se confirma la instalación de pip, podemos instalar TensorFlow y Keras ejecutando el siguiente comando:

$pip install theano
$pip install tensorflow
$pip install keras


Written by Tutor


Comments

This post currently has no responses.

Leave a Reply